Unable to gift plants

  • When I click the "gift" link on any of my plants, it takes me to the center of my garden, instead of bringing up a gift link page like it should.


    Edit: It is impossible for me to abandon or trash plants (or seeds) as well. Every time I click any of my plant links - gift, abandon, or trash - I get sent to the center of my garden. Breeding appears to work correctly; at least, it shows a list of other plants I can breed a plant with; since I haven't actually tried breeding, I don't know whether or not it will produce a seed, so I can't say for certain. But it doesn't take me to the center of my garden, like the other three options do.


    This really needs to be looked into. Since we're supposed to gift to someone on Valentine's Day in order to get a gift from the post pixie (assuming you're going to activate that), then at least some of us won't be able to do this.

  • Ok, so apparently the links don't work when using Chrome, but do work when using a different browser. (For me, it was the Avast browser.)


    That doesn't mean that this is not a bug, just that there's a work-around. I had already tried clearing my cache and various other things, and the problem persists so long as I'm using Chrome.

  • Does this happen to all your plants or only specific plants? There should be no difference at all between browsers. The only thing that I could imagine might be some adblocker that you have installed in some browsers but not in the once that are working?

  • For me, it happens with all plants. If an ad blocker is causing it, it's a recent development, and I haven't changed what extensions I have installed. That said, an ad blocker app could have gotten an update I wasn't aware of, which could cause a different effect beyond what it used to.


    Nope, just turned all my extensions off; still having that problem. I think I'll keep them all turned off until this problem is sorted, however.


    Keep in mind, this isn't an error per se; I just get redirected to the center of my garden whenever I make an attempt to gift, abandon, or trash. I'm not sure why an extension at my end would redirect me to a specific location at your end. Keep in mind that the URL it's directing me to is "https://flowergame.net/garden/1906". It's not the generic "flowergame.net", and it's not a safety page; it's the center of my garden specifically. That means that the redirect is most likely at the server end, I think. Sort of like an "I'm not sure what you're trying to do, so I'm going to send you right here," kind of thing.


    It didn't start happening until right after this last server change. I haven't been able to use those links since that occurred.


    Edit: I just talked to my friend Zab, who is also on this site. She uses Edge, and hadn't had any extensions installed, and is having this problem. So it's not just Chrome, but I have no idea what commonality the two of us might have.

  • Can you try it right now? So the problem is if you click on someones gift link and instead of getting the flower you are getting redirected to your garden? And you are not seeing some red message when redirected? Because it should show an error message every time it forwards you to your garden. Can you PM me a gift link you are trying to take?

  • Btw, something that may or may not be related: If you try to go directly to "flowergame.net" or "www.flowergame.net", you get a DNS error; at least I do, on all of my browsers. It's like the main site is somehow not connected to anything, nor does the site have a main page. We USED to go to the main wild garden page, where we could select from three seeds and/or create an account. This change may or may not be related to this issue, but it's something to consider.


    Keep in mind that if the main site is not navigable, we won't be getting new members, as that's the most likely URL that anyone would try to go to.

  • I'm not getting any red message or error message at all. I click "gift" or "trash" or "abandon" on any of my plants, and I just get sent to my center garden page. No error messages or anything else; it simply doesn't work.


    I'm not sure how I can send you a gift link that I'm attempting to create, when it doesn't allow me to get to a page that shows a gift link. Since the gift links get generated on the fly, there's no way for me to know what the gift link would be, since I'm not getting it. I think we're communicating at cross-purposes here; you're assuming I can't ACCEPT gift links, but the problem is that I can't CREATE them.


    The problem isn't when I click on someone else's gift link; those work fine (although I am not interested in taking them). It's when I try to CREATE a gift link for someone else to take a plant of mine, that's when this problem occurs.

  • Good catch. Seems like some browsers try to open the "www." version by default. I've added them for now to our DNS server so the game can now be reached via "www.flowergame.net" as well.


    I identified the issue you guys have with gift, trash etc. For a quick workaround if you logout and login again it's gonna work (the remember me function is causing this issue right now). I will fix this as soon as possible. Thank you very much for all your patience on this.

  • Oh, then that issue might be what's causing the gift/trash/abandon problem! Yes, I can see how that would be specifically browser related. If Avast browser isn't trying to add the www, and Chrome and Edge are, then those two browsers would have that problem!


    Unfortunately, Chrome and Edge are probably the most common browsers out there. Edge because Microsoft (which is why I hate it), and Chrome because developers love it, because it follows the WWW standards most closely. (Or did a dozen years ago, back when I was studying web development.) I only installed Avast on my system for a one-time situation I had where I needed to browse a site incognito (Avast has that ability; most browsers don't), and I've rarely used it since then.

  • Alia we did some DNS changes that probably was causing this. The game should be back and stable without errors. If you see a 404 page just try to refresh the page and it goes away (as your browser might have cached the 404 error page).


    MiaSkywalker Yes thats why the game is now reachable via http://www.flowergame.de, flowergame.de, http://www.flowergame.net and flowergame.net to cover all our bases.


    @All: I've identified the issues you guys had that was preventing people from trashing there flowers and gifting them. The problem was that if you are only authenticated because of the remember me feature we require you to login via password (to prevent someone using your computer trashing all your flowers). Unfortunately our login had an issue where if you had remember me function enabled it considered yourself as logged in already and redirected you to your garden. This is now fixed and everything should be working.